Ruby, Rails dan Gems

Posted in Scripting & Development , written by wahya on 06 August 2012

Ruby

Semua share server di Mongkiki saat ini telah terinstall Ruby 1.8.7 (patchlevel 334) yang memiliki level kompatibilitas yang lebih baik. Saat ini kami belum memiliki ETA untuk Ruby 1.9. Namun saat ini kami masih mengusahakan agar opsi ini ada pada setiap server. Baca artikel berikut untuk mengetahui lebih jelas mengapa kami belum bisa upgrade ke Ruby 1.9

Rails

Jika versi Rails yang terinstall secara default tidak begitu relevan, Anda pun bisa melakukan installasi sendiri pada home direktori server Anda. Beberapa server lama kami masih terinstall versi terbaru dari branch Rails 2. Hal tersebut kami lakukan agar klient yang menggunakan Rails 2.x tidak terganggun oleh veris Rails 3.x dimana ada beberapa hal pada Rails 2.x yang tidak kompatibel di Rails 3.x

Gems

Kami menginstall beberapa set yang sangat minim pada server. Jika Anda ingin menginstall gems Anda sendiri, Anda harus membuatnya dengan Bundler atau dengan melakukan setting RubyGems Anda sendiri. Beberapa Gems memerlukan akses root untuk instllasi. Mohon kontak support kami jika Anda mengalami masalah dalam instalasi Gems.

Baca juga: Bagaimana menggunakan applikasi Rails dalam direktori sub folder

Share on Facebook or , read previous article or go to the next one.